Install Intel Rapid Storage Technology Driver on Windows 10

I Recently  purchased some shiny new 256GB Samsung 850 PRO SSDs to replace my older boot drive setup in my desktop. After getting them installed and configured I took the opportunity to perform a fresh installation of Windows 10 Build 10041 followed by a direct upgrade to Build 10049.

After the upgrade I was presented with a .NET Framework error when trying to install the latest Intel Rapid Storage Technology driver.

Considering Windows 10 includes .NET 4.5x in the box I figured the issue was related to an OS version check, and sure enough after looking at the log I could see the check was for anything NT 6.0 – 6.3 with .NET 4.5x. Although Windows 10 presents the 6.3 kernel versions to legacy Win32 applications I suspect the RST setup is having trouble pairing up the two together, perhaps due to .NET 4.6 being included by default.

Anyway, I’m rambling on now so here’s the fix.

This procedure was tested with Build 10049, other builds may differ.

What you need:

  • Intel Rapid Storage Technology Driver (Duh!) Link
  • 7-Zip 9.20 or 9.38 Beta Link

Procedure:

1. Extract the SetupRST.exe file with 7-Zip

2. Right click on the MSI installer for your OS type and select “Properties”

3. Under the Compatibility tab select “Run this program in compatability mode for previous version of Windows”

 

That’s it! All you need to do now is install  from the MSI file and it should be successful 🙂

 

6 thoughts on “Install Intel Rapid Storage Technology Driver on Windows 10

  1. Thank you. I installed new driver cause Windows 10 detected my raid HDDs as
    SSD, but there is no result. Do you know something about it?

  2. Thanks, works great! I tried to use Winrar first for extracting, but it seems to auto-extract the .msi-files. Use 7-zip for this to make it work!

  3. Thank you! Intel’s driver installers are really some of the worst. They will choke on all matter of things, new Windows version, unknown .NET versions etc. How many times do they need to be told that you DO NOT block install on versions you don’t know, you just show a warning.

  4. I added your solution over on TenForums.com – lots of folks were having this issue. They could install the drivers by extracting them and manually installing through Dev mgr., but not the application.

    Brilliant, absolutely brilliant.

Leave a Reply

Your email address will not be published. Required fields are marked *

*